燃烧的梦想
 燃烧的梦想,流水的时光 

2006-03-18 Sat

补充,mapserv在EL4下的编译环境

长城小站是由志愿者支持的公益性网站,无固定经济来源。2012年小站台历是由各方网友赞助图片、设计、印刷精心制作的纪念品,用于小站运营经费筹款。
欢迎您购买小站台历,支持长城小站与小站博客的发展。
mapserver8.0的在Linux下编译也很顺利,只要所需的支持包安装完全。

下列是在redhat EL4U2上(安装了Linux编译环境),在安装完mapserve基础环境后,如果要自行编译mapserver所需的支持包列表

mapserve网上提供的(EL4对应于fc3的rpm包):
http://mappinghacks.com/rpm/fedora/3/
gdal-devel
gd-devel
proj-devel
libjpeg-devel
libpng-devel
geos-devel
pdflib-devel
ming-devel


redhat安装盘中提供的:
xorg-x11-devel
php-devel
freetype-devel
fontconfig-devel-2.2.3-7.i386.rpm
postgresql-libs
postgresql-devel


初学者注意,选择的开发包需和软件包的版本号和子版本号都须严格对应
例如mapserver上geos同时提供了
geos-2.1.1-mh4.i686.rpm
geos-2.1.4-mh1.i686.rpm
geos-devel-2.1.1-mh4.i686.rpm
geos-devel-2.1.4-mh1.i686.rpm
如果你先前安装的是geos-2.1.4-mh1.i686.rpm,则需要geos-devel-2.1.4-mh1.i686;
不能是geos-devel-2.1.1-mh4.i686

再比如,你的postgresql是从mapserver网站上下的,则继续用mapserv网站的对应的postgresql-libs
和postgresql-devel,但如果你是在安装redhat时就安装了postgresql的话,那么你就必须去光盘上继续寻找上述两个支持包。


火箭人于 2006-03-18 23:57:01 发表在分类:OpenDesktopGis
(49634次点击) | 标签:  



 评论
 · 发表新帖
 留言总数0帖 页次:1/0 每页:20条 

Power by 小站博客, Ver0.7 update at 2006-03-04